Subscribe to the::unwired's RSS Feedthe::unwired at Twitterthe::unwired on Facebookthe::unwired on Google Plus
the::unwired Article
SITE: Server and Code Upgrade Successfully Done [UPDATE 2]
Posted by Arne Hess - on Friday, 06.07.07 - 19:34:51 CET under 06 - Site News - Viewed 17239x
Tagged under: []

As announced earlier today the server was down for some "maintenance" and in fact it was 'a little' bit more. If you can read this posting, what I hope you can, you read the::unwired on a brand new server! My trustworthy Windows 2003 Server from 2004 came into the years which made a server upgrade necessary. And if you do something like this, it's the right time to do some more backend maintenance in addition. Therefore we've also upgrade from PHP4 to PHP5 as well as we upgraded from MySQL4 to MySQL5. And if you do such an environment upgrade, you also have to upgrade the site code and therefore we've upgraded the CMS from v3.6 to v4.2 as well as we've upgraded the forum from v1.2 to 1.2.15 (whatever all these version numbers mean for you) and had some additional code cleanup.

MySQL

Anyway - the new server is a real powerhouse running on a 2.2 GHz Dual Core AMD Operton CPU, sporting 4 GB RAM, 2 x 250 GB RAID1 HDD and running Windows Server 2003 Standard:

This allows me to add a couple of new features in the upcoming months (stay tuned - I have some cool new features in the pipeline). For now, I hope you enjoy the performance increase as much as I do and the next 48 hours I will use to make sure all/most of the previously existing features are working fine on the new environment as well. If you face any trouble, please let me know!

Also I want to thank fellow Windows Mobile user Radek Hulán from F-ART AGENCY, Ltd. for his support and the hard work. Basically he's the man who made everything working again!

UPDATES: Okay, here we go with a couple of updates.

  • First of all it seems the transition went pretty smooth and I haven't found too many glitches yet (you?)
  • Looks like not all DNS servers around the world have fetched the new IP address of the new server but latest on Monday morning it should be propagated to all DNS servers. Such a transition can take up to 48 hours.
  • Yesterday night the spammers were back. Just a couple of hours after the new server and system went alive, bots and infected zombie PCS have started to post spam into the forums again and therefore I had to disable anonymous forum posting. However, as you know, I'm a big fan of anonymous posting - I don't want to force anyone to register for a forum account. I want to hear your opinions, thoughts and ideas, I don't want to collect E-Mail addresses or count "registered" users. So I worked a little bit on a new script which I put into the code now. This should keep bots and and zombie PCs from posting automatically and therefore anonymous forum posting is back. Nevertheless, I have to keep an eye on the forum and check if the script is really working 100 % well. In worst case I have to disable (temporarily) anonymous posting again but I promise I'm working on it to make it available in any case again.

All right, that's the latest info from me. If you notice anything wrong, please let me either know by E-Mail or in the comments bellow.

UPDATE: Looks like I've configured the E-Mail server wrong and therefore two important E-Mail addresses were down. If you sent an E-Mail to info@theunwired.net or news@theuwired.net, we've never received it but you got a message that the E-Mail address doesn't exists (anymore). I'm really sorry for this mistake. The E-Mail addresses are back and working now, please feel free to send you previous E-Mail again.

Cheers ~ Arne


 

Related Articles SITE:

Comments